Possible networking issues at the Curtis Laws Wilson Library

Resolved

We have received no further complaints and all systems look stable at this time. Marking this issue as resolved.
Posted Nov 20, 2025 - 08:53 CST

Monitoring

The Network team has looked at all the pertinent device logs and no obvious cause for the degraded service has been identified. We will continue to monitor for any continuing problems but at this time service appears to have been restored.
Posted Nov 19, 2025 - 11:14 CST

Investigating

S&T IT is aware of possible issues with the networking at the Curtis Laws Wilson Library and is investigating now.
Posted Nov 19, 2025 - 09:07 CST
This incident affected: Network.