NX software unavailable

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 16:29 CDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 02, 2025 - 15:48 CDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 02, 2025 - 15:30 CDT

Identified

What is happening?
NX software is now available. NX is engineering CAD software used in classes, design teams, and for independent projects. Siemens provided a new license file this afternoon, and the server has been updated. Please launch NX from AppsAnywhere.
Posted Sep 02, 2025 - 11:35 CDT
This incident affected: AppsAnywhere.