Google Cloud Platform Outage

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 09:21 CDT

Investigating

There is an outage related to Google Cloud Platform that is affecting some services at S&T. More info can be found here: https://status.cloud.google.com/regional/americas
Posted Jun 12, 2025 - 16:54 CDT
This incident affected: Canvas, Google Apps, and Other S&T IT Services.