IT Help Ticket System (TDX) - Degraded Performance

Resolved

The IT Help Ticket System is operational. TeamDynamix has resolved the concern (https://tdx.statuspage.io/).
Posted Nov 06, 2025 - 13:59 CST

Investigating

We are investigating reports of degraded performance of our IT Help Ticket System, TeamDynamix (TDX).
Posted Nov 06, 2025 - 12:44 CST
This incident affected: IT Help Ticket System (TeamDynamix).