MOREnet reported fiber cut in Rolla - Non service impacting

Identified

Fiber splicing crews are on site performing repairs.
Estimate time for repair completion is noon today.
Posted Nov 18, 2025 - 07:45 CST

Investigating

MORENET has reported a fiber cut in Rolla.
This has taken half of the ICN network offline; however, our redundant circuits are functioning as designed.
There is no impact to campus services.
The cause of the damage is currently under investigation, and there is no ETA for repair at this time.
Posted Nov 17, 2025 - 21:25 CST