Get webhook notifications whenever Missouri S&T IT Services & Systems creates an incident, updates an incident, resolves an incident or changes a component status.
This was a successful change. Contact IT if you have any issues.
Posted Sep 02, 2026 - 18:09 CDT
Update
All security updates have been completed. While the automated configuration pushes were successful, some workstations may take longer to check in and receive the updates.
If you experience any issues, please contact the Helpdesk for assistance.
Posted Aug 25, 2026 - 22:14 CDT
Update
With the change underway, we are about 50% complete, if you have the new profile already downloaded, you may connect successfully.
Posted Aug 25, 2026 - 21:47 CDT
Monitoring
Missouri S&T’s IT team is updating the connection profiles used by devices connecting to the campus VPN. Users who connect to the S&T general VPN will need to update their VPN profile to continue connecting after the change is completed at 10 p.m. tonight (Tuesday, Aug. 25).
The change will not go into effect until after 10 p.m.
Posted Aug 25, 2026 - 17:06 CDT
This incident affected: Virtual Private Network (VPN).