Data feed issues impacting Work Phone

Resolved

Corrections to the data have been completed successfully.
Posted Aug 20, 2025 - 15:36 CDT

Investigating

UMSystem IT staff have identified an issue with the data feed from HR that may impact work phone numbers listed in the Global Address List in Microsoft Exchange.

Staff are working to correct the issue and notify those impacted. No interaction on the part of the account holder is needed.
Posted Aug 13, 2025 - 21:14 CDT
This incident affected: Campus Email.