IT Ticketing System Degraded Service

Resolved

Vendor has resolved issue and system remains operational. All services are fully restored.
Posted Sep 09, 2026 - 15:26 CDT

Monitoring

Vendor has updated that issue is resolved and currently being monitored. Access should be restored and technicians are monitoring.
Posted Sep 09, 2026 - 10:32 CDT

Identified

The IT ticketing system (Team Dynamix) is currently experience degraded performance. Technicians are limited on their response time due to the current performance and access. Vendor has posted updates and is working to resolve.
Posted Sep 09, 2026 - 10:29 CDT
This incident affected: IT Help Ticket System (TeamDynamix).