Canon printers are currently unavailable for printing on campus.

Resolved

Canon Print servers have been restored and printing is working again.
Posted Mar 09, 2026 - 10:54 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2026 - 16:44 CST

Investigating

We have corrected a setting on the Canon print server and are monitoring the incident.
Posted Mar 04, 2026 - 15:11 CST
This incident affected: Printing.