MST Wireless Network - Partial Outage

Resolved

This incident has been resolved.
Posted Nov 08, 2025 - 15:31 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 08, 2025 - 10:58 CST

Investigating

The primary WIFI (MST network) is down on campus. The issue is being investigated.
Posted Nov 08, 2025 - 09:12 CST
This incident affected: Campus WIFI Network.