Outbound calls to T-Mobile are degraded.

Update

A solution continues to be investigated. If you experience a call failure to a number you know to be carried by T-Mobile, please contact the S&T IT Help Desk to report the number and date/time you attempted the call.
Posted Mar 16, 2026 - 10:00 CDT

Update

Through collaborative effort with our service providers, an issue has been identified. A solution is being investigated.
Posted Mar 05, 2026 - 13:38 CST

Identified

We are aware of an issue affecting outbound calls made between the campus phone system to phone numbers carried by T‑Mobile. Some callers may experience degraded call quality or be unable to complete calls. Our team is working with our upstream provider to identify the cause and resolve the issue.
Posted Feb 26, 2026 - 10:25 CST
This incident affects: Campus VOIP Telephone Service.