**SCHEDULED NETWORK MAINTENANCE** to occur beginning at 8:00 AM Saturday, 3/21/26 - 11:59 PM Sunday, 3/22/26

Update

First Day 2 group of 25 buildings is complete.
Posted Mar 22, 2026 - 11:12 CDT

Update

The Network team is now resuming after today's safety briefing
Posted Mar 22, 2026 - 08:48 CDT

Update

Our 4th group of buildings is complete. The maintenance window tomorrow (3/22/26) will be extended from 12:00pm to 11:59pm (midnight)
Posted Mar 21, 2026 - 20:36 CDT

Update

We are working on our 4th group of buildings.
Posted Mar 21, 2026 - 18:52 CDT

Update

We are starting on our third group of buildings
Posted Mar 21, 2026 - 16:51 CDT

Update

Starting Second Group of Buildings
Posted Mar 21, 2026 - 14:25 CDT

Update

We have completed our first group of buildings critical to campus operations - Computer Science Building and UPD
Posted Mar 21, 2026 - 11:43 CDT

Update

Starting with First Building Group
Posted Mar 21, 2026 - 09:57 CDT

Update

We are currently establishing the uplinks between new and old switches in both PK and CS
Posted Mar 21, 2026 - 09:46 CDT

Update

Our Network team is starting the MAINTENANCE, currently running pre-checklist and making sure all staff are in place to get started.
Posted Mar 21, 2026 - 08:40 CDT

Identified

All campus network services, including internet, phones, access systems, and alarms, will be temporarily unavailable​.
Multiple cascading outages are planned to be 5-10 minutes per building ​, But may exceed 10 minutes per building​.
Posted Mar 20, 2026 - 12:11 CDT
This incident affects: AppsAnywhere, Campus Email, Campus VOIP Telephone Service, Campus WIFI Network, Campus Wired Network, Canvas, HPC, Google Apps, Horizon View VDI, ID Card Scan System, IT Help Ticket System (TeamDynamix), IT Web Applications, Joe'SS/PeopleSoft, Microsoft Teams, Multi-Factor Authentication (MFA), My S&T Intranet Portal, Network, Printing, Other S&T IT Services, Zoom, and Virtual Private Network (VPN).