Campus printing is experiencing an outage

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 17:04 CDT

Investigating

Printers on campus are having sporatic issues. Investigating.
Posted Oct 10, 2025 - 09:16 CDT
This incident affected: Printing.