STRAUMANIS-JAMES HALL - Network is currently down - Techs are Investigating.

Resolved

Outage caused by a UPS Failure.
Network service has been restored.
Posted Mar 23, 2026 - 16:39 CDT

Investigating

We are currently investigating this issue.
Posted Mar 23, 2026 - 16:20 CDT
This incident affected: Network.