www.mst.edu is down

Resolved

Additional checks have passed, and this issue has been resolved.
Posted May 09, 2026 - 07:07 CDT

Monitoring

Public facing services have been restored. Internal systems are being verified, root cause is still being investigated.
Posted May 08, 2026 - 08:49 CDT

Update

Issues related to outages have been identified, and services are being helathchecked to ensure functionality
Posted May 08, 2026 - 07:51 CDT

Identified

Issue with primary www.mst.edu is resolved, remaining MST website properties and services are being investigated.
Posted May 08, 2026 - 06:55 CDT

Investigating

The University of Missouri S&T's primary website is down; the root cause is not known at this time. Teams work working to restore services.
Posted May 08, 2026 - 06:43 CDT