S&T Connect (Starfish) Data Issue

Monitoring

Data sync has started processing again and technicians are working with the vendor to insure data sync is stable and all data is restored.
Posted May 11, 2026 - 08:15 CDT

Identified

A data sync to S&T Connect (Starfish) has impacted some data available in the platform. Technicians have identified the data sync issue and are working with the vendor to resolve and restore data available in the platform.
Posted May 08, 2026 - 09:55 CDT
This incident affects: Other S&T IT Services.