VPN errors

Resolved

S&T OpenVPN has been restored.
Posted Mar 09, 2026 - 11:02 CDT

Investigating

Some users are reporting errors when using the VPN. We are investigating.
Posted Mar 07, 2026 - 13:36 CST
This incident affected: Virtual Private Network (VPN).