Foxit PDF Editor Outage

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 18:08 CDT

Identified

Foxit PDF Editor for Windows and Mac requires a license update. IT will push a mandatory upgrade to all Mac computers and AppsAnywhere installed Windows computers with a valid Foxit PDF Editor license. An interruption may be experienced while individual computers apply the mandatory license upgrade.
Posted Jun 16, 2025 - 17:07 CDT