NX License Down

Resolved

This incident has been resolved.
Posted Sep 05, 2026 - 21:17 CDT

Identified

We have identified the issue and are working with the vendor to get a new license file.
Posted Sep 01, 2026 - 10:40 CDT
This incident affected: Other S&T IT Services.