IT website under construction

Resolved

Identified desired changes have been. More update to follow.
Posted Aug 11, 2026 - 17:03 CDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 11, 2026 - 17:01 CDT

Identified

Our IT page, it.mst.edu, is currently being updated and is still under construction. During this time, some links may not work as expected or may be temporarily unavailable.

We appreciate your patience as we work to improve the site. If you need immediate assistance, please contact the IT Service Desk at it.mst.edu.
Posted Jul 13, 2026 - 17:36 CDT
This incident affected: Other S&T IT Services.