Printer servers not functioning

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 12:46 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2025 - 11:32 CDT

Update

Technicians have resolved the printing problem. If you are still having printing issues, we recommend rebooting your system. If you continue to have issues, please reach out to the IT Help Desk.
Posted Oct 24, 2025 - 09:02 CDT

Update

We are continuing to investigate this issue.
Posted Oct 24, 2025 - 08:59 CDT

Investigating

An upgrade to the printer operating system has caused a disruption in the printer operating system on campus. Technicions are investigating.
Posted Oct 24, 2025 - 08:37 CDT
This incident affected: Printing.