Netgroup/Security Group Management Tool

Resolved

Issue with the netgroup tool has been corrected.
Posted Nov 13, 2025 - 18:39 CST

Investigating

Netgroup management tool is experiencing issues and technicians are investigating to resolve the issue.
Posted Nov 13, 2025 - 14:44 CST
This incident affected: Other S&T IT Services.