Partial Network Outage in the Physics building

Resolved

Switch failed, replacement complete.
Service restored at 9:30
Posted Mar 12, 2026 - 10:01 CDT

Identified

S&T IT is aware of a partial network outage in the Physics building due to the power outage this morning. S&T IT is working to restore networking at this time. Individuals in this building may encounter issues with Wi-Fi, Ethernet, printing, and desk phones until services are restored.
Posted Mar 12, 2026 - 08:38 CDT
This incident affected: Campus VOIP Telephone Service, Campus WIFI Network, Campus Wired Network, Network, and Printing.