Campus wide Network outages reported "blip"

Resolved

The issue was identified, and the network recovered automatically after a 40-second outage. We remain observant as the network adjusts to the new equipment installed this weekend.
Posted Mar 24, 2026 - 11:11 CDT

Monitoring

The issue has been identified, and no additional outages are expected.
Posted Mar 23, 2026 - 12:24 CDT

Investigating

We are investigating errors
Posted Mar 23, 2026 - 10:43 CDT
This incident affected: AppsAnywhere, Campus VOIP Telephone Service, Campus WIFI Network, Campus Wired Network, HPC, Horizon View VDI, ID Card Scan System, IT Help Ticket System (TeamDynamix), IT Web Applications, Joe'SS/PeopleSoft, Microsoft Teams, Multi-Factor Authentication (MFA), My S&T Intranet Portal, Network, Printing, Other S&T IT Services, and Virtual Private Network (VPN).