Unexpected power outage on campus

Update

We are continuing to work on a fix for this issue.
Posted Mar 09, 2026 - 11:40 CDT

Update

Power has been restored to Castleman Hall, Engineering Management Building, Havener Center and the Innovation Lab.
Bertlesmeyer Hall is expected to have a multi-day power outage.

Network services have been restored to all locations with the exception of a single switch that has failed in Engineering Management.
We are working to replace the switch ASAP.
Posted Mar 09, 2026 - 11:36 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 09, 2026 - 10:21 CDT

Investigating

Phyfac has notified us of a unexpected power interruption on campus.
The following buildings are affected.

Innovation Lab, Havener Center, Engineering Management, Bertelsmeyer, Castleman

Network in those buildings will be down once the UPS units die.
Posted Mar 09, 2026 - 10:20 CDT
This incident affects: Network.