Partial Network interuption in Rolla Suites South building

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 11:22 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 20, 2025 - 09:46 CDT

Investigating

A network switch failure has been identified in Rolla Suites South.
Posted Aug 20, 2025 - 09:45 CDT
This incident affected: Network.