Jira Services Restored

Resolved

Services remain operational and no further issues have come up.
Posted May 11, 2026 - 08:14 CDT

Monitoring

Jira Services have been restored and vendor is monitoring performance. All services show as operational and technicians are continuing to monitor for any service disruptions.
Posted May 08, 2026 - 08:12 CDT

Identified

Jira Services by Atlassian have been downgraded. Vendor has posted technicians are working on the issue to resolve multiple components.
Posted May 07, 2026 - 21:06 CDT
This incident affected: S&T Applications/Software (Jira).