Campus network down in some buildings

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 09:47 CST

Monitoring

As a result of the power outage the campus network may be unavailable in some buildings. We are monitoring and will work to bring buildings back online as soon as possible.
Posted Nov 12, 2025 - 08:31 CST
This incident affected: Campus WIFI Network and Campus Wired Network.