Partial Campus Network Outage - Storm Impact

Resolved

All network services have been restored and are stable.
Posted Mar 20, 2025 - 15:04 CDT

Update

Network service has been restored to all campus buildings, except Kennedy Experimental Mine (UPD stated they have no power).
We will continue to monitor as RMU continues to restore power in the area.
Posted Mar 15, 2025 - 16:40 CDT

Identified

The Missouri S&T campus is currently experiencing a partial network outage due to severe weather Friday evening. The Network team is actively working to restore connectivity as quickly as possible.
We apologize for the inconvenience and appreciate your patience during this time. We will provide updates as we work to resolve the issue.
Posted Mar 15, 2025 - 14:51 CDT
This incident affected: Campus Wired Network and Network.