Internet service interuption

Resolved

The outage did not originate within the Missouri S&T campus network, nor with our direct internet service provider. It occurred further upstream within the broader internet infrastructure and impacted a larger geographic region. As a result, the disruption was outside of both campus and provider control, affecting multiple networks beyond our immediate service area.
All services have been restored.
Posted Apr 16, 2026 - 15:33 CDT

Investigating

S&T experienced a brief internet outage. Engineers are currently investigating the cause.
Posted Apr 16, 2026 - 15:01 CDT
This incident affected: Network.