Partial Network outage in Electrical Engineering Building

Update

We are continuing to monitor for any further issues.
Posted Apr 19, 2026 - 21:12 CDT

Monitoring

Once power was restored, the Networking team identified switch failures caused by the outage. Replacement switches were configured and deployed. Only one failed switch remains, located in the Electrical Engineering building; its replacement will be installed first thing Monday morning.
Posted Apr 19, 2026 - 21:10 CDT

Identified

Several buildings on campus have lost power due to a transformer failure. As a result the network in those buildings is also down. There is no ETA on power restoration at this time.
Posted Apr 19, 2026 - 16:09 CDT
This incident affects: Campus WIFI Network and Campus Wired Network.