Microsoft 365 services degraded

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 15:00 CDT

Monitoring

Users may experience issues accessing or using multiple Microsoft 365 services, including Microsoft Teams and Outlook
ID: MO1274150

Issue type: Incident

Status

Service Restored

Impacted services

Microsoft 365 suite

Details

Title: Users may experience issues accessing or using multiple Microsoft 365 services, including Microsoft Teams and Outlook

User impact: Users may have experienced intermittent delays in email delivery and access to Microsoft 365 services.

Final status: Following our mitigation of the identified network-level disruption, our remediation actions have completed and service health has been restored across affected Microsoft 365 services. We’ve confirmed through service telemetry that service has fully recovered and remains healthy.

Scope of impact: Users accessing Microsoft 365 services in North America and Europe were primarily affected by this issue. The majority of customer reports originated from the US, Netherlands, UK, and Canada, though users in other regions may have been impacted as well.

Start Time: Wednesday, April 8, 2026, at 2:38 PM UTC

End Time: Wednesday, April 8, 2026, at 3:05 PM UTC

Preliminary root cause: Configuration changes implemented by an external network provider affected internet traffic routing via this service provider, which resulted in connectivity issues impacting access to multiple Microsoft 365 services. After identifying the issue, we redirected service traffic through alternate network paths to mitigate the impact and restore service availability.

Next steps:

- We’re continuing our analysis of the underlying systems to understand the conditions that led to this issue and to implement safeguards that help prevent recurrence.

We'll provide a preliminary Post-Incident Report within two business days and a final Post-Incident Report within five business days.

Is this message helpful?
Posted Apr 08, 2026 - 11:18 CDT
This incident affected: Microsoft Teams.