Get webhook notifications whenever Missouri S&T IT Services & Systems creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 10, 2026 - 09:00 CST
Scheduled
The S&T IT team continues to enhance the university’s network infrastructure and is tentatively planning a major network upgrade 9 a.m.-4 p.m. Saturday, Jan. 10. Some network services including the internet, phones, access systems and alarms will be intermittently unavailable.
Posted Jan 08, 2026 - 16:13 CST
This scheduled maintenance affected: AppsAnywhere, Campus VOIP Telephone Service, Campus WIFI Network, Campus Wired Network, HPC, Horizon View VDI, ID Card Scan System, IT Web Applications, My S&T Intranet Portal, Network, Printing, Other S&T IT Services, and Virtual Private Network (VPN).