TeamDynamix technician portal (IT facing) experiencing errors

Resolved

Update from vendor:

Incident resolved
We’ve deployed a fix to address unhandled errors when accessing tickets in Work Management. The issue was caused by a misconfiguration during a maintenance deployment and has now been fully resolved.
Posted Dec 05, 2025 - 21:02 CST

Investigating

The technician portal is displaying errors when opening tickets, no further information at this time. Impact currently appears to be limited to IT staff with no impact seen on the customer facing portal.
Posted Dec 05, 2025 - 19:59 CST
This incident affected: IT Help Ticket System (TeamDynamix).