Partial network outage in Rock Mechanics Building affecting some WiFi and wired connections

Resolved

The switch has been replaced and connectivity has been restored.
Posted Nov 04, 2025 - 18:38 CST

Update

We are continuing to work on a fix for this issue.
Posted Nov 04, 2025 - 17:42 CST

Identified

A network switch in the building has failed. A replacement is being built. Networking staff will install a new switch and will status page when network service is restored.
Posted Nov 04, 2025 - 17:41 CST
This incident affected: Network.