Partial outage of some Microsoft services, impact to teams, scope unknown at this time

Resolved

All licenses have been restored to any accounts incorrectly identified for decommissioning.
Posted Aug 27, 2025 - 14:13 CDT

Investigating

We are seeing reports of problems accessing portions of Microsoft Teams, some channels affected, but not all. Full scope of the outage is unknown at this time, but it is confirmed on other sources (DownDetector, etc.)
Posted Aug 20, 2025 - 08:08 CDT
This incident affected: Microsoft Teams.