Photos.mst.edu

Resolved

The SSO access to photos.mst.edu has been fully restored and is operational.
Posted Mar 02, 2026 - 10:06 CST

Monitoring

A new single sign on configuration has been implemented with the vendor and technicians are monitoring for any further issues.
Posted Feb 27, 2026 - 08:48 CST

Identified

Single Sign-on (SSO) for photos.mst.edu is currently unavailable and access to university content is blocked. Technicians are working with the vendor and SSO provider to resolve.
Posted Feb 23, 2026 - 10:57 CST
This incident affected: S&T Applications/Software (Photoshelter (photos.mst.edu)).