International Calling Unavailable

Monitoring

We have implemented a fix and are monitoring the results
Posted Aug 20, 2026 - 14:33 CDT

Update

Knowns so far: the international travel dialing app (3011) will immediately hang up when you press pound, indicating that there is something not negotiating correctly with our upstream International and Long distance provider(s)
Posted Aug 20, 2026 - 13:26 CDT

Investigating

It has been reported and confirmed that international calling through the S&T Phone System is unavailable. Technicians are investigating the cause.
Posted Aug 20, 2026 - 13:24 CDT
This incident affects: Campus VOIP Telephone Service.