AWS east outage

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 05:44 CDT

Update

AWS issues have been resolved however there is still high error rates and latency being reported on the service itself. Canvas has been restored to operational status as have the other impacted services. Minor issues are to be expected until the error rates and latency returns to normal and we will continue to monitor the services impacted.
Posted Oct 20, 2025 - 18:49 CDT

Update

We are continuing to monitor the status of the outage. Amazon Web Services (AWS) are slowly recovering. Panopto and Turnitin appear to have recovered. There is no ETA on full restoration of AWS and we will continue to monitor.
Posted Oct 20, 2025 - 16:45 CDT

Update

Known services impacted has been expanded to Canvas, Zoom, Panopto, and others. We will continue to monitor https://health.aws.amazon.com/health/status for information on the root cause.
Posted Oct 20, 2025 - 08:59 CDT

Monitoring

Starting as early as 2 am AWS east began experiencing outages that effect services hosted on AWS. We are monitoring the outage.
Posted Oct 20, 2025 - 07:42 CDT
This incident affected: Canvas, Other S&T IT Services, and Zoom.