Emerson Building Power Outage- Network down

Resolved

Electricity has been restored and all network services in Emerson Engineering Hall have been restored.
Confirmed with UPD that cameras and locks are also in normal operation.
Posted Jun 08, 2025 - 06:34 CDT

Identified

Emerson Hall is currently without main power; only emergency lighting is operational. Card swipes, cameras, and the IT network rack are down due to the outage. Physical Facilities is onsite investigating, with a possible fuse issue identified in the EE area.
Posted Jun 07, 2025 - 19:51 CDT
This incident affected: Network.