All IT applications, TDX, AppsAnywhere offline due to certificate expiration on campus load balancer

Monitoring

Certificate replaced, services believe to be back in service at this time.
Posted Feb 27, 2026 - 20:07 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 27, 2026 - 19:53 CST
This incident affects: AppsAnywhere, Horizon View VDI, IT Help Ticket System (TeamDynamix), IT Web Applications, and Other S&T IT Services.