MS Teams multiple reports of outage/inability to open windows desktop client or Web version
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 09:29 CDT
Update
We have additionally seen problems with the mobile client.
Posted Apr 24, 2024 - 09:12 CDT
Investigating
We are currently investigating this issue.
Posted Apr 24, 2024 - 08:21 CDT
This incident affected: Microsoft Teams.