Evoko Conference Room Scheduling display partial outage

Resolved

A fix has been implemented and services have been restored.
Posted Apr 21, 2026 - 14:37 CDT

Investigating

Some conference rooms using the Evoko room displays are not currently showing correct meeting information. Technicians are investigating.
Posted Apr 21, 2026 - 10:02 CDT
This incident affected: Other Applications / Services (Evoko Conference Room Scheduling).