Azure services degraded

Resolved

Microsoft has resolved this issue
Posted Oct 10, 2025 - 09:20 CDT

Monitoring

Microsoft experienced an outage related to Azure earlier today.

https://azure.status.microsoft/en-us/status

----------------------------------
Warning

Mitigation Applied - Issues accessing the Azure Portal


Impact Summary: Starting at 19:43 UTC on 09 October 2025, a subset of customers may experience issues accessing the Azure Portal, Entra Admin Portal, Intune Admin Portal and Portal extensions. The availability of Azure resources or the management of resources via programmatic methods like API is not impacted. There is no impact to the availability of Azure resources as a result of this.

Current Status: We’ve have failed traffic away from content delivery service resources that the Azure Portal interface relies on to mitigate. We are also performing additional steps to purge caches to ensure additional residual impact is mitigated. We are monitoring for full recovery, and some customers should be able to access. For customers continuing to experience issues, we recommend attempting a cache refresh on your browser. The next update will be provided in 60 minutes or as events warrant.

This message was last updated at 22:04 UTC on 09 October 2025
Posted Oct 09, 2025 - 17:07 CDT