Multiple IT services offline due to expired certificates

Resolved

This incident has been resolved -- monitored systems show working and no user reports of issues.
Posted Apr 09, 2026 - 17:04 CDT

Monitoring

All known expired certificates have been replaced and services show healthy
Posted Apr 06, 2026 - 10:06 CDT

Update

git-classes.mst.edu SSL certificate has been updated and services show healthy
Posted Apr 06, 2026 - 10:00 CDT

Update

voiceweb.mst.edu SSL certificate has been updated and services show healthy
Posted Apr 06, 2026 - 09:51 CDT

Update

git.mst.edu SSL certificate has been updated and services show healthy
Posted Apr 06, 2026 - 09:50 CDT

Identified

Certificates on voiceweb.mst.edu, git.mst.edu, and git-classes.mst.edu are expired and impacting services.
Posted Apr 06, 2026 - 08:24 CDT
This incident affected: Campus VOIP Telephone Service and Other S&T IT Services.